mushlab-iot/nix/shell.nix
Sebastian Wendel b4ac6e2f6a
initial commit
2023-06-08 01:51:13 +02:00

37 lines
643 B
Nix

{self, ...}: system:
with self.pkgs.${system};
mkShell {
name = "mushlab-iot";
nativeBuildInputs =
[
# Development
editorconfig-checker
pre-commit
yaml-language-server
git
]
++ lib.optionals (pkgs.hostPlatform.system == "x86_64-linux") [
vscodium-fhs
fritzing
]
++ [
# Linter
yamllint
# Nix
alejandra
nixUnstable
nil
# Service
mosquitto
esphome
# Misc
reuse
];
shellHook = ''
${self.checks.${system}.pre-commit-check.shellHook}
'';
}