nix-zephyr-sdk/shells/nix.nix
Sebastian Wendel 92a1367216
All checks were successful
build / check (push) Successful in 27s
build / build (push) Successful in 2m10s
first commit
2023-09-11 17:33:19 +02:00

19 lines
307 B
Nix

{self, ...}: system:
with self.pkgs.${system};
mkShell {
name = "nix-dev";
buildInputs = [
alejandra
deadnix
git
nil
nixUnstable
pre-commit
reuse
statix
];
shellHook = ''
${self.checks.${system}.pre-commit-check.shellHook}
'';
}