srx-platform-nix/hosts/dev-vm/hardware.nix
Sebastian Wendel b910dc465e first commit
2024-07-04 13:47:18 +02:00

38 lines
806 B
Nix

{ self, modulesPath, config, ... }:
{
imports = [
(modulesPath + "/installer/scan/not-detected.nix")
(modulesPath + "/profiles/qemu-guest.nix")
self.nixosModules.filesystems-zfs
];
age.secrets.clevisSystem.file = ./clevis.age;
boot = {
initrd = {
systemd = {
enable = true;
inherit (config.systemd) network;
};
network.enable = true;
availableKernelModules = [
"ahci"
"xhci_pci"
"virtio_pci"
"virtio_scsi"
"sr_mod"
"virtio_blk"
];
clevis = {
enable = true;
useTang = true;
devices."vda".secretFile = config.age.secrets.clevisSystem.path;
};
};
loader = {
systemd-boot.enable = true;
efi.canTouchEfiVariables = true;
};
};
}