srx-platform-nix/hosts/srxgp00/hardware.nix
Sebastian Wendel b910dc465e first commit
2024-07-04 13:47:18 +02:00

23 lines
471 B
Nix

{ self, inputs, modulesPath, ... }:
{
imports = with inputs; [
(modulesPath + "/installer/scan/not-detected.nix")
self.nixosModules.hardware
self.nixosModules.hardware-cpu-amd
srvos.nixosModules.hardware-hetzner-online-amd
];
boot = {
initrd = {
availableKernelModules = [
"xhci_pci"
"ahci"
"nvme"
];
kernelModules = [ ];
};
swraid.enable = true;
zfs.devNodes = "/dev/disk/by-uuid";
};
}