hcs-html-ccs/flake.nix
2024-04-17 11:04:05 +02:00

43 lines
1 KiB
Nix

{
description = "HCS Coding Challenge";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
flake-parts.url = "github:hercules-ci/flake-parts";
};
outputs = inputs@{ flake-parts, ... }:
flake-parts.lib.mkFlake { inherit inputs; } {
systems = [ "x86_64-linux" "aarch64-darwin" "x86_64-darwin" ];
perSystem = { pkgs, config, system, inputs', self', ... }: {
devShells.default = pkgs.mkShell {
nativeBuildInputs = with pkgs; [
# ide
vscodium
# formater
alejandra
nixfmt
nodePackages_latest.prettier
# lsp
nil
tailwindcss-language-server
nodePackages_latest.vscode-html-languageserver-bin
nodePackages_latest.vscode-css-languageserver-bin
# node
nodePackages_latest.nodejs
nodePackages_latest.yarn
# html
html5validator
vscode-extensions.ritwickdey.liveserver
];
};
};
};
}