nixos-wsl/nix/devshell.nix
Sebastian Wendel 9f2899ff0c first commit
2024-09-09 22:08:49 +02:00

25 lines
447 B
Nix

{
perSystem =
{ pkgs, config, ... }:
{
devShells = {
default = pkgs.mkShell {
packages = with pkgs; [
deadnix
git
git-lfs
ipcalc
nil
shellcheck
statix
treefmt
];
shellHook = ''
${config.pre-commit.installationScript}
'';
};
};
};
}