39 lines
1 KiB
Nix
39 lines
1 KiB
Nix
{
|
|
description = "srx personal robotnix configuration";
|
|
|
|
nixConfig = {
|
|
extra-substituters = [ "https://robotnix.cachix.org" ];
|
|
extra-trusted-public-keys = [ "robotnix.cachix.org-1:+y88eX6KTvkJyernp1knbpttlaLTboVp4vq/b24BIv0=" ];
|
|
};
|
|
|
|
inputs.robotnix.url = "github:nix-community/robotnix";
|
|
|
|
outputs = { self, robotnix, ... }:
|
|
let
|
|
ccache.enable = true;
|
|
microg.enable = true;
|
|
in
|
|
{
|
|
robotnixConfigurations = {
|
|
localTesting = robotnix.lib.robotnixSystem ({ config, pkgs, ... }: {
|
|
device = "x86_64";
|
|
flavor = "vanilla";
|
|
inherit ccache microg;
|
|
});
|
|
|
|
pixel7a = robotnix.lib.robotnixSystem ({ config, pkgs, ... }: {
|
|
device = "lynx";
|
|
flavor = "grapheneos";
|
|
inherit ccache microg;
|
|
});
|
|
|
|
pixel4a = robotnix.lib.robotnixSystem ({ config, pkgs, ... }: {
|
|
device = "sunfish";
|
|
flavor = "vanilla";
|
|
inherit ccache microg;
|
|
});
|
|
};
|
|
|
|
defaultPackage.x86_64-linux = self.robotnixConfigurations.localTesting.img;
|
|
};
|
|
}
|