This repository hosts the code for srx.digital, a fast static website built with Astro and React. https://srx.digital/
Find a file
2024-11-20 01:25:08 +01:00
.forgejo/workflows upgraded astro config and packes to latest version 2023-10-31 16:42:59 +01:00
.vscode version bump and added fmt setting 2024-05-17 15:12:57 +02:00
nix latest changes 2024-11-20 01:25:08 +01:00
public added contact details 2024-10-12 14:18:09 +02:00
src latest changes 2024-11-20 01:25:08 +01:00
.envrc updated components 2024-04-23 18:46:19 +02:00
.gitignore fixed astro check directories 2024-03-04 18:18:43 +01:00
astro.config.mjs updated components 2024-04-23 18:46:19 +02:00
flake.lock latest changes 2024-11-19 23:48:39 +01:00
flake.nix flake follow nixpkgs and update 2024-05-17 14:37:21 +02:00
package.json latest changes 2024-11-20 01:25:08 +01:00
README.md Simplified startup project 2024-03-03 13:45:20 +01:00
tailwind.config.ts replace colors and fonts with variables 2024-03-10 02:59:20 +01:00
tsconfig.json updated options in regards to imports and intelli sense 2024-03-13 17:02:54 +01:00
yarn.lock latest changes 2024-11-20 01:25:08 +01:00

srx.digital: Portfolio Sebastian Wendel

srx.digital

🧞 Commands

All commands are run from the root of the project, from a terminal:

Node

Command Action
yarn install Installs dependencies
yarn dev Starts local dev server at localhost:3001
yarn build Build your production site to ./dist/
yarn preview Preview your build locally, before deploying
yarn astro ... Run CLI commands like astro add, astro check
yarn astro --help Get help using the Astro CLI

Nix

Command Action
nix run .#serve Starts local dev server at localhost:3001
nix build .#srx-digital Build your Nix Package