zephyr-wasm-poc/shell.nix
2023-10-03 16:32:31 +02:00

84 lines
1.6 KiB
Nix

{
self,
nix-zephyr-sdk,
...
}: system:
with self.pkgs.${system};
with nix-zephyr-sdk.packages.${system};
mkShell {
name = "zephyr-wasm-poc";
buildInputs = [
# Development
editorconfig-checker
git
pre-commit
reuse
shellcheck
vscode-extensions.mkhl.direnv
vscode-extensions.ms-vscode.cmake-tools
vscode-extensions.ms-vscode.cpptools
vscodium-fhs
yaml-language-server
yamllint
# Nix
nixUnstable
nil
alejandra
# Actions
actionlint
forgejo-actions-runner
# C/CPP
bear
bison
ccache
cmake
cmake-format
cmake-language-server
coccinelle
dfu-util
flex
gdb
gnumake
gperf
gtest
libffi
libusb
ncurses
ninja
# Hardware
esptool
espup
linuxPackages.usbip
mpfshell
mpremote
mpy-utils
rshell
zephyr-sdk
(python310.withPackages (ps:
with ps; [
anytree
cbor
click
intelhex
kconfiglib
ply
psutil
pyelftools
pyserial
setuptools
tabulate
west
]))
];
shellHook = ''
${self.checks.${system}.pre-commit-check.shellHook}
export CMAKE_PREFIX_PATH=$CMAKE_PREFIX_PATH:${nix-zephyr-sdk.packages.${system}.zephyr-sdk}/cmake
export OPENOCD=${nix-zephyr-sdk.packages.${system}.zephyr-sdk}/bin/openocd
export OPENOCD_DEFAULT_PATH=${nix-zephyr-sdk.packages.${system}.zephyr-sdk}/share/openocd/scripts
'';
}